GoboLinux bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000382Recipespublic2008-11-13 02:082009-05-10 01:42
Reporterkeisangi 
Assigned Tomohjive 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Summary0000382: kde4.1.3 fails and loop on Compiling Phonon version 4.2.0
Description
as the title says,
trying to install kde 4.1.3 fails and loop on phonon.

using either this command:
for kde in $(FindPackage -t r -s kde 4.1.3 | sed 's,.*/,,' | sort | uniq );do name=$(echo $kde | sed 's/--.*//'); ver=$(echo $kde | sed 's/.*--\(.*\ )--.*/\1/'); Compile --batch $name $ver; done

or plain:
Compile kde-base

i get same error, looping:


CheckDependencies: KDE-Base-Workspace is not installed.
CheckDependencies: Compile recipe for KDE-Base-Workspace 4.1.3 or skip this dependency? [C]Compile/[S]Skip/[CA]Compile All/[SA]Skip All
ca

CheckDependencies: KDE-Libs is installed, but version 3.5.8 does not match given dependency.
CheckDependencies: KDE-Libs 4.1.3 (recipe) will be Compiled

CheckDependencies: Phonon is not installed.
CheckDependencies: Phonon 4.2.0 (recipe) will be Compiled

CheckDependencies: Qt is installed, but version 3.3.7 does not match given dependency.
CheckDependencies: Qt 4.4.3 (recipe) will be Compiled

CheckDependencies: Fontconfig is installed, but version 2.4.2 does not match given dependency.
CheckDependencies: Fontconfig 2.6.0 (recipe) will be Compiled

CheckDependencies: FreeType is installed, but version 2.1.10 does not match given dependency.
CheckDependencies: FreeType 2.3.7 (recipe) will be Compiled

CheckDependencies: LibXML2 is installed, but version 2.6.27 does not match given dependency.
CheckDependencies: LibXML2 2.7.2 (recipe) will be Compiled

CheckDependencies: SQLite is not installed.
CheckDependencies: SQLite 3.6.4 (recipe) will be Compiled

CheckDependencies: Strigi is not installed.
CheckDependencies: Strigi 0.5.11 (recipe) will be Compiled

CheckDependencies: CLucene is not installed.
CheckDependencies: CLucene 0.9.21 (recipe) will be Compiled

CheckDependencies: Automoc is not installed.
CheckDependencies: Automoc 0.9.84 (recipe) will be Compiled

CheckDependencies: Shared-MIME-info is not installed.
CheckDependencies: Shared-MIME-info 0.51 (recipe) will be Compiled

CheckDependencies: Intltool is not installed.
CheckDependencies: Intltool 0.40.3 (recipe) will be Compiled

CheckDependencies: Perl-XML-Parser is not installed.
CheckDependencies: Perl-XML-Parser 2.36 (recipe) will be Compiled

CheckDependencies: Perl-XML-Writer is not installed.
CheckDependencies: Perl-XML-Writer 0.604 (recipe) will be Compiled

CheckDependencies: LibCaptury is not installed.
CheckDependencies: LibCaptury 0.3.0 (recipe) will be Compiled

CheckDependencies: Capseo is not installed.
CheckDependencies: Capseo 0.3.0 (recipe) will be Compiled

CheckDependencies: Linux-PAM is not installed.
CheckDependencies: Linux-PAM 1.0.1 (recipe) will be Compiled

CheckDependencies: QImageBlitz is not installed.
CheckDependencies: QImageBlitz 0.0.4 (recipe) will be Compiled
Compile: Using passed recipe /Files/Compile/Recipes/Phonon/4.2.0-r1
GetRecipe: Trying to get /Files/Compile/Recipes/Phonon/4.2.0-r1
Compile: Recipe placed in /Files/Compile/Recipes/Phonon/4.2.0-r1
Compile: Compiling Phonon version 4.2.0, revision r1.
Compile: Unpacking file /Files/Compile/Archives/phonon-4.2.0.tar.bz2...
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /System/Links/Executables/gcc
-- Check for working C compiler: /System/Links/Executables/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /System/Links/Executables/c++
-- Check for working CXX compiler: /System/Links/Executables/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at cmake/FindQt4.cmake:1455 (MESSAGE):
  Qt qmake not found!
Call Stack (most recent call first):
  CMakeLists.txt:14 (find_package)


-- Configuring incomplete, errors occurred!
sed: -e expression 0000001, char 21: Unmatched ( or \(
Compile: Locating a recipe for KDE-Base-Runtime ...
Compile: Found recipe for KDE-Base-Runtime
GetRecipe: Trying to get http://gobolinux.org/recipe-store/KDE-Base-Runtime--4.1.3-r1--recipe.tar.bz2 [^]
GetRecipe: Downloading recipe from http://gobolinux.org/recipe-store/KDE-Base-Runtime--4.1.3-r1--recipe.tar.bz2 [^]
Compile: Recipe placed in /Files/Compile/Recipes/KDE-Base-Runtime/4.1.3-r1
Compile: Checking dependencies...

CheckDependencies: KDE-Libs is installed, but version 3.5.8 does not match given dependency.
CheckDependencies: Compile recipe for KDE-Libs 4.1.3 or skip this dependency? [C]Compile/[S]Skip/[CA]Compile All/[SA]Skip All
Additional Informationjust an idea:

maybe it would be good to try recipes against
latest available gobo iso:
i mean vanilla 014.01 with just updated Compile and Scripts,
before making them available to the public.

eventually a chrooted env + quota ?
anyway this test environement should match available public release 1:1 (fresh.. no additionnal installation, no customization ..)




TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000938)
giamba (developer)
2008-11-15 01:31

This seems a problem caused by Scripts or Compile. Which versions were you using?
Phonon declares Qt as its dependency, so Compile should actually compile Qt first.
(0000939)
keisangi (reporter)
2008-11-15 02:02

i used latest available version of Scripts and Compile.
the error have been discussed on #gobolinux, Mohjive knows about it too
(0000954)
mohjive (administrator)
2009-05-10 01:42

This should be resolved with later versions of Phon, where it declares dependency of Qt. This is included from version 4.3.1 of Phonon.

- Issue History
Date Modified Username Field Change
2008-11-13 02:08 keisangi New Issue
2008-11-15 01:31 giamba Note Added: 0000938
2008-11-15 02:02 keisangi Note Added: 0000939
2009-05-10 01:42 mohjive Note Added: 0000954
2009-05-10 01:42 mohjive Status new => resolved
2009-05-10 01:42 mohjive Resolution open => fixed
2009-05-10 01:42 mohjive Assigned To => mohjive


Copyright © 2000 - 2017 MantisBT Team
GoboLinux Bug Tracker