GoboLinux bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000398Recipes[Compile] public2009-02-28 10:472009-06-11 08:52
Reporterjfsantos 
Assigned Tomohjive 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Summary0000398: Compile cannot finish Glibc installation and breaks system
DescriptionI already reported this bug at the mailing list, just copying text from there so the bug is properly documented here.

Last night I did a fresh install (using the Base profile) of Gobo
under my notebook. The base install does not include Wireless-Tools
and WPA_Supplicant requires Qt to be installed, I booted under another
distro, mounted my filesystem with /dev and /proc binded, chrooted to
it and then installed the new versions for Scripts and Compile. I
wanted to upgrade Glibc and GCC and then build the whole system again
with the newer recipes, linking them to the new Glibc. Fair enough.
Then, I tried to Compile Glibc 2.8 and got everything broken. Got this
error during the compilation:

/bin/bash: error while loading shared libraries: libtinfo.so.5: cannot
open shared object file: No such file or directory

and the build stopped. And then, zsh also was not working anymore,
because of the same error (it is related to some ncurses library). I
could do nothing then, but exited the chroot to look for system
inconsistencies. Found that /Programs/Glibc/Current still pointed to
2.5, but /Programs/Glibc/Settings was pointing to the 2.8 Settings
dir. I tried to fix it by hand but still cannot chroot or boot under
my new system, because there's still the Ncurses error.
Additional InformationWe figured at IRC that what happens is that ldconfig runs without a proper ld.so.conf at /Programs/Glibc/Settings and this breaks all dynamic linking after it (breaking Compile, ls, and everything that depends on a shared library). The linking can be fixed by running "/Programs/Glibc/2.5/sbin/ldconfig -f /Programs/Glibc/2.5/Resources/Defaults/Settings/ld.so.conf".

Probably the Settings folder needs to be copied before "make install". I tried adding code to check if the Settings directory exists and then copy the files if true, but this approach hadn't worked.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000951)
mohjive (administrator)
2009-05-10 00:30

Resolved with an updated recipe, that copies needed files Resources/Default/Settings before install. Still Glibc needs UnionSandbox to install, but that will be fixed with next Scripts release.

- Issue History
Date Modified Username Field Change
2009-02-28 10:47 jfsantos New Issue
2009-05-10 00:24 mohjive Project Compile => Recipes
2009-05-10 00:30 mohjive Note Added: 0000951
2009-05-10 00:30 mohjive Status new => resolved
2009-05-10 00:30 mohjive Resolution open => fixed
2009-05-10 00:30 mohjive Assigned To => mohjive


Copyright © 2000 - 2017 MantisBT Team
GoboLinux Bug Tracker