|Anonymous | Login | Signup for a new account||2017-11-24 12:16-0800|
|My View | View Issues | Change Log | Roadmap|
|View Issue Details|
|ID||Project||Category||View Status||Date Submitted||Last Update|
|0000423||Scripts||[Scripts]||public||2010-07-10 04:26||2010-07-10 04:26|
|Target Version||Fixed in Version|
|Summary||0000423: Scripts used by Rootless require python >= 2.5|
|Description||Even though the python scripts are provided in Scripts/lib/python-2.3/..., some of the scripts use features of python found only in 2.4 and 2.5. These are quite easily patched and allow for Rootless to be installed on a much wider variety of systems that have not yet been updated. Here is a list of the problem I was having when trying to install Rootless under Scientific Linux with python 2.3:|
subprocess (requires >= 2.4):
This is easily fixed by including the subprocess.py module from the Python sources (as this is backwards compatible with 2.2). Need to check licensing restrictions of including this file.
Generator expressions (requires >= 2.4)
Fixed by using list comprehensions instead.
Unified try/catch/except (requires >= 2.5)
Fixed by using nested try's
frozenset (requires >= 2.4)
Fixed by using sets module.
I have not check other scripts yet to see if they have similar problems that could be easily fixed -- these were the ones that confronted me.
In general, it would be really nice if Rootless could be installed with as few dependencies as possible. Once it is installed, the user can easily update Python etc. as needed.
|Additional Information||I have provided a patch for Scripts--2.10.2--i686 here:|
|Tags||No tags attached.|
|2010-07-10 04:26||mforbes||New Issue|
|Copyright © 2000 - 2017 MantisBT Team|