GoboLinux bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000423Scripts[Scripts]public2010-07-10 04:262010-07-10 04:26
Assigned To 
PlatformOSOS Version
Product VersionSVN 
Target VersionFixed in Version 
Summary0000423: Scripts used by Rootless require python >= 2.5
DescriptionEven though the python scripts are provided in Scripts/lib/python-2.3/..., some of the scripts use features of python found only in 2.4 and 2.5. These are quite easily patched and allow for Rootless to be installed on a much wider variety of systems that have not yet been updated. Here is a list of the problem I was having when trying to install Rootless under Scientific Linux with python 2.3:

subprocess (requires >= 2.4):

This is easily fixed by including the subprocess.py module from the Python sources (as this is backwards compatible with 2.2). Need to check licensing restrictions of including this file.

Generator expressions (requires >= 2.4)

Fixed by using list comprehensions instead.

Unified try/catch/except (requires >= 2.5)

Fixed by using nested try's

frozenset (requires >= 2.4)

Fixed by using sets module.

I have not check other scripts yet to see if they have similar problems that could be easily fixed -- these were the ones that confronted me.

In general, it would be really nice if Rootless could be installed with as few dependencies as possible. Once it is installed, the user can easily update Python etc. as needed.
Additional InformationI have provided a patch for Scripts--2.10.2--i686 here:

http://bitbucket.org/mforbes/gobo_install/src/tip/Patches/Scripts--2.10.2--i686.patch [^]

See also:
http://bitbucket.org/mforbes/gobo_install/issue/6/ [^]

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-07-10 04:26 mforbes New Issue

Copyright © 2000 - 2018 MantisBT Team
GoboLinux Bug Tracker